Jan7

【原创】Phalcon4.X版本安装报错方案解决

Author: leeon  Click: 815   Date: 2019.01.07 @ 20:14:26 pm Category: php

最新的Phalcon4版本开始需要引入PSR模块,出处来源于https://blog.phalconphp.com/post/merry-christmas-and-phalcon-4.0.0-alpha1-released

如果没有安装psr模块则会在启动php或者php-fpm报错“Fatal error: Class 'psr\container\containerinterface' not found in Unknown on line 0”,出现segmentation fault。除了需要安装psr模块意外,一定要注意在php.ini中配置extension的顺序。

在加载phalcon.so模块之前就必须先加载psr.so模块。so模块加载顺序依赖于你在php.ini配置中的上下顺序。因此,你必须保证如下的顺序结构:

extension=psr.so

extension=phalcon.so



TAG:   phalcon psr

    评论
    • 提交

    分类

    标签

    归档

    最新评论

    shallwe99在10:21:17评论了
    【原创】如何在微信小程序开发中正确的使用vant ui组件
    默一在09:04:53评论了
    Berkeley DB 由浅入深【转自架构师杨建】
    Memory在14:09:22评论了
    【原创】最佳PHP框架选择(phalcon,yaf,laravel,thinkphp,yii)
    leo在17:57:04评论了
    shell中使用while循环ssh的注意事项
    呵呵哒啦在15:06:33评论了
    【原创】最佳PHP框架选择(phalcon,yaf,laravel,thinkphp,yii)

    我看过的书

    链接

    其他

    访问本站种子 本站平均热度:6898 c° 本站链接数:29 个 本站标签数:459 个 本站被评论次数:93 次